Hast du auch schon immer gedacht, dass die Welt doch nicht so rund ist, wie sie zu sein scheint? Hattest du jeher das Gefühl, dass die Kreiszahl eher quadratisch sein müsste?
Dann bist du genau hier richtig! Blockforum ist die neue Minecraft-Community. Werde Mitglied und teile mit uns Deine Leidenschaft. Wir freuen uns auf dich!

Der Zugriff auf das Forum ist für Gäste eingeschränkt, als registrierter Benutzer würden Dir alle Funktionen (wie z.B. Bildvergrößerung und Downloads) im Forum zur Verfügung stehen.

Minecraft mit NVIDIA-Grafikkarte

    • Tutorial

      Minecraft mit NVIDIA-Grafikkarte

      Wer ein Notebook mit einem integrierten Grafikchip und einer NVIDIA-Grafikkarte besitzt, wundert sich vielleicht, warum Minecraft nicht die leistungsstärke NVIDIA-Grafikkarte erkennt. Daran ist aber nicht Minecraft "Schuld", sondern es ist dafür eine Einstellung erforderlich. Das Minecraft zu den Anwendungen gehört, die eine höhere Grafikleistung erforden, muss man dem Notebook erst einmal "sagen".

      Standardmäßig wird bei einem Notebook der integrierte Grafikchip verwendet und nur bei Anwendungen, die eine hohe Grafikdarstellung benötigen, wird automatisch umgeschaltet. Wenn statt dem integrierten Grafikchip, die NVIDIA-Grafikkarte genutzt wird, kann dabei mehr Akkustrom verbraucht werden.

      Öffnet die NVIDIA Systemsteuerung.
      Unter der Spalte "Wählen Sie eine Aufgabe ..." auf 3D-Einstellungen verwalten klicken.
      Rechts das Register "Globale Einstellungen" anklicken. Unter Bevorzugter Grafikprozessor könnt ihr nun aus der Liste eine Auswahl vornehmen. Wählt hier NVIDIA-Hochleistungsprozessor und klickt unten links auf Übernehmen, dann wird die NVIDIA-Grafikkarte global (also immer) verwendet. Ihr setzt somit die automatische Verwaltung außer Kraft.



      Eine globale Umstellung würde ich euch allerdings nicht empfehlen, da nicht jede Anwendung diese Grafikkarte benötigt wird und eine Zuweisung auch für jede Anwendung separat möglich ist.

      NVIDA zuweisen - Grafikfehler beheben

      Wieder unter der 3D-Einstellungen verwalten nun auf das Register Programmeinstellungen klicken. Unter "Ein Programm wählen, das benutzerdefiniert ..." findet ihr eine Liste von Anwendungen. Die Minecraft.exe sollte da auch angezeigt werden. Diese könnt ihr auswählen und und aus der Liste "Den bevorzugten Grafikprozessor für dieses Programm wählen" NVIDIA-Hochleistungsprozesssor auswählen und unten rechts auf übernehmen klicken. Von nun an wird die Minecraft.exe mit der NVIDIA-Grafikkarte ausgeführt.

      Startet das Spiel und lasst es euch per F3 im Spiel anzeigen.
      Ihr habt nun diese Einstellungen gemacht und eventuell auch Optifine installiert und eingestellt. Dennoch stellt ihr fest, dass die Kantenglättung nicht stimmt, Moiré-Effekte zu sehen sind und die Grafik irgendwie fade aussieht.



      Dagegen kann man etwas machen. :) Nachfolgende Einstellungen können auch für einen PC verwendet werden.

      Öffnet wieder die NVIDIA Systemsteuerung und geht zum Register Programmeinstellungen.
      1. Bei "Ein Programm wählen, das benutzerdefiniert ..." daneben auf den Button Hinzufügen klicken. Sucht nun auf eurem Notebook/PC die Java.exe. Standardmäßig befindet sich die Anwendung in eurem Programmverzeichnis.
      (Ich habe Java an einem anderen Ort installiert, daher ist auch auf dem Bild nicht der Standardpfad zu sehen.)
      2. Aus der Liste "Den bevorzugten Grafikprozessor für dieses Programm wählen" den NVIDIA-Hochleistungsprozesssor auswählen.




      Unter "Die Einstellungen für dieses Programm festlegen" findet ihr eine Liste von Standardeinstellungen. Diese passen nicht 100% zu Minecraft.
      (Die dargestellten Einstellmöglichkeiten können auch bei NVIDIA-Grafikkarten unterschiedlich sein.)

      Folgende Änderungen vornehmen (rechte Spalte "Einstellungen"):




      Anisotrope Filterung
      Anwendungsgesteuert
      Antialiasing-Modus
      Beliebige Anwendungseinstellungen außer Kraft setzen
      Antialiasing-Transparenz
      2x oder 4x (2x reicht oft schon aus.)
      Texturfilterung-Anisotrope Abtastoptimierung
      Aus
      Texturfilterung-Negativer LOD-Bias
      Zulassen






      Nun noch auf Übernehmen klicken und das Spiel starten. Die Grafikfehler sollten nun nicht mehr auftreten.

      Hallo :)

      Versuche mal statt java.exe die C:\Program Files\Java\VERSIONSNUMMER\bin\ javaw.exe zu verwenden. Ansonsten die Schritte wie oben.
      Wichtig dann auch:

      Loreley schrieb:

      2. Aus der Liste "Den bevorzugten Grafikprozessor für dieses Programm wählen" den NVIDIA-Hochleistungsprozesssor auswählen.

      Nicht vergessen, nach Änderungen dann unten rechts bei der NVIDIA-Systemsteuerung auf den Button Übernehmen zu klicken. Oft wird dies vergessen sich weil der Button unten in der Ecke befindet.

      Du könntest du auch versuchen NVIDIA als globalen Grafikprozessor einzustellen.

      LG :F:

      Herzlich Willkommen DieseKartoffel,

      bei mir hats anfangs auch nicht geklappt, mir hats dann geholfen folgende Programme hinzuzufügen:
      java.exe und javaw.exe, die liegen bei mir im Verzeichnis C:\Program Files\Java und da dann noch die aktuellste Java-Version auswählen
      minecraft.exe, sollte automatisch angezeigt werden
      Bei "Bevorzugter Grafikprozessor" dann die NVidia-Card auswählen, nicht das Selbstbestimmende.
      Und zum Schluss unten rechts in der Ecke den "Übernehmen"-Button drücken, sonst speichert der die Einstellungen nicht.

      Hallo!
      Bei mir klappt die ganze Sache irgendwie nicht.. Folgendes:
      Ich mache alles so wie gesagt, will Java in den Nvidia Einstellungen speichern usw. usw..
      Aber es speichert einfach nicht. Ich drücke 'Übernehmen', schließe die Einstellungen, öffne sie wieder und schaue nach.. und Java wurde nicht gespeichert,
      deswegen hört mein Minecraft weiterhin nicht auf zu flackern. Minecraft kann ich in den Nvidia Settings auch nicht speichern, es verschwindet nach dem schließen einfach wieder.
      Ich wäre wirklich dankbar für Hilfe.. ;(
      Hallo Titandesu :)

      Sehr seltsam. So etwas ist bei mir noch auf keinem Computer vorgekommen.

      Verhindert evt. eine Firewall-Antivirus-Software diese Änderung? Deaktiviere diese dann einfach kurz für die Zeit der Änderung.
      Du könntest noch versuchen die NVIDIA-Systemsteuerung mit Administrationsrechten zu starten.
      Zu guter Letzt fällt mir dann nur noch eine Neuinstallation des Treiber ein.

      Welches Betriebssystem hast du?

      ​Ich habe da ein Problem mit meiner Nvidia-Grafigkarte und Minecraft.
      ​Wenn ich für Minecraft den Nvidia Hocheistungsprozessor auswähle und Minecraft starte, wird das Startfeld, wo normalerweise MOJANG steht, weiß angezeigt; und wenn es dann geladen hat sieht man oben das Feld zu schleißen, minimieren und zum verkleinern. Sonst sieht man nichts.
      ​Wäre nett, wenn Du mir helfen könntest.
      Danke
      Hallo :)

      Da wäre es wichtig zu wissen, ob du den "alten" ober bereits den neuen Launcher von Minecraft benutzt.
      Ist bei deinem Profil im Feld JVM Arguments etwas eingetragen und ist dieses Feld aktiv?
      Eine aktuelle Java-Version ist ebenfalls wichtig.
      Nur die Umstellung des Grafikprozessors hat i.d.R. noch keine Auswirkungen auf Minecraft.
      Erst bestimmte Einstellungen beim Grafiktreiber wirken sich auf das Spiel aus.
      Du könntest auch probieren, die Einstellungen bei Minecraft zu belassen und nur bei javaw.exe den Grafikprozessor umzustellen.
      Ist diese weiße Seite dann dauerhaft? Ich hatte soetwas noch nie.

      Ich habe das fast schon vermutet, dass du den neuen Launcher benutzt.
      Da dieser noch eine Beta-Status hat, habe ich diesen noch nicht installiert. Von daher ist es grad schwierig dir zu helfen. :(
      Wenn der Launcher Probleme beim Nvidia Prozessor macht, würde ich diesen dann testweise nur javaw.exe und java.exe zuweisen.

      Die weiße Seite kann aber auch möglicherweise überhaup nichts damit zu tun haben.
      Der Launcher ist, mal einfach ausgedrückt, nur der Rahmen, die Inhalte kommen direkt vom Mojang Server. Wenn da die Seite down ist oder möglicherweise auch die Internetverbindung unzureichend, sieht man nur eine weiße Seite.

      Ich werde mal in den nächsten Tagen den neuen Launcher testen. :)

      Es ist schwierig zu helfen, da es ja extrem viele Möglichkeiten und Kombinationen, bedingt durch die verwendete Hard- und Software, gibt.

      Ich würde so vorgehen:
      Bei der Nvidia Systemsteuereung ersteinmal wieder alles auf Standard zurücksetzen.
      Dann als 1. die Einstellungen bei der javaw.exe machen. Minecraft starten und mit F3 schauen ob der Nvidia angezeigt wird.
      Ist dies dann bereits der Fall brauchst du keine weiteren Änderungen machen.
      Wenn nicht, MC beenden und als nächstes die Einstellungen bei java.exe machen und wieder MC starten und gucken ob Nvidia angezeigt wird.

      Was mir noch grad dazu einfällt. Wenn dein Betriebssystem 64 Bit ist, dann solltest du die Java Windows Offline (64-Bit) installieren.

      LG

      Ich habe ein Problem glaub ich mit dem Nvidia Programm.
      Ich kann bei mir nicht den bevorzugten Grafikprozess einstellen, da dies bei mir gar nicht angezeigt wird.
      Es ist zwar möglich die javaw.exe auszuwählen aber nur die einzelnen Einstellungen darunter kann man einstellen.
      Hab es auch schon mit älteren Versionen von dem Nvidia Programm versucht.
      Kann mir da bitte wer bei helfen?

      PS:
      Betriebssystem: Windows 10 pro x64
      Graka: Geforce GTX 970
      java Version: Java 8 64bit
      Hallo :)

      Das dies nicht angezeigt wird, ist eigenartig.
      Möglicherweise ist der Treiber nicht korrekt installiert.
      Manchmal killt auch ein Windows 10 Update den Nvidia . :(

      Satostaro schrieb:

      Hab es auch schon mit älteren Versionen von dem Nvidia Programm versucht.


      Nimm den aktuellen Nvidia-Treiber. geforce.com/hardware/desktop-gpus/geforce-gtx-970
      Bevor du diesen installierst, solltest du älteren Versionen restlos deinstallieren.
      Dafür eignet sich dieses Tool gut: chip.de/downloads/Display-Driv…staller-DDU_65992840.html

    Du bist nicht angemeldet.
    Anmelden oder Registrieren